CASA Requirements: Supported Operating Systems

This page lists operating systems supported by the CASA Project.

This page will be revised periodically as we plan future releases, or gain or lose resources.

STATUS: Approved - Current Requirements for CASA 4.2.0.

Current

CASA 4.2.0

Runtime support

CASA packages must run correctly on:

  • Debian 7.0
  • Fedora 17
    • Note: the current version of Fedora is 18. ESO requires Fedora 17.
  • OS X 10.7
  • OS X 10.8
  • Redhat 5.7
  • Redhat 6.3
  • Ubuntu 12.04 LTS

Source: verbal: Jeff Kern from 2013 ALMA Software Leads Meeting

Development support

CASA developers must be able to build and test on:

  • Debian 7.0
  • Fedora 17
    • Note: the current version of Fedora is 18. ESO requires Fedora 17.
  • OS X 10.7
  • OS X 10.8
  • Redhat 5.7
  • Redhat 6.3
  • Ubuntu 12.04 LTS

Source: verbal: Jeff Kern from 2013 ALMA Software Leads Meeting

-- ScottRankin - 2013-06-04

Historic

CASA 4.1.0

Run time support

CASA packages must run correctly on:

  • OS X 10.6
  • OS X 10.7
  • OS X 10.8
  • Redhat 5.7
  • Redhat 6.3

Source: verbal: Jeff Kern

Development support

CASA developers must be able to build and test on:

  • OS X 10.6
  • OS X 10.7
  • Redhat 5.7+

Source: verbal: Jeff Kern

-- ScottRankin - 2013-05-07
Topic revision: r15 - 2013-11-20, ScottRankin
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding NRAO Public Wiki? Send feedback