CASA Requirements: 3rd Party Development Tools and Libraries

This page lists 3rd party development tools and libraries used to develop CASA. These are collectively called 3rd party packages.

STATUS:
  • Policies: DRAFT
  • Collecting Requirements for CASA 4.2.0.

Addition and Update policy

Addition of new, and updates to existing 3rd party packages to CASA requires review and approval by the CASA Architect and CASA Management.

  • 3rd party packages may not be added less than 2 months before a release.
  • 3rd party packages may not be updated less than 1 month before a release.
  • 3rd party packages may be deleted any time, once we demonstrate that package is no longer required for CASA development.

CASA 4.2.0

Required Versions

CASA requires exact matches for version numbers for the following packages, unless otherwise indicated.

Tools

These tools are required to build CASA. Some may be integrated into CASA to provide user features.

tool minimum version required by/for/to requirement source
CMake >=2.8.5 Hide the complexity of Makefiles. internal
Doxygen 1.4.7 Generate documentation from source code. internal
GCC >=4.1.2 Compile C/C++. host OS
gfortran >=4.1.2 Compile Fortran. Host OS
Graphviz 2.34.0 Generate graphs from text. Graphviz will use if available
!MacPorts 2.2.1 Manage some 3rd party packages on OS X. internal - OS X only
Python 2.7.5 CASA interpreted language. internal
SWIG 2.0.4 Generate python bindings to C++ code. internal
Xcode >=4.6.2 OS X IDE MacPorts - OS X only - required version varies by OS X version

Libraries

These C, C++, and Fortran libraries are required to implement parts of CASA or by tools used by CASA. Python packages are tracked separately below.

library required version required by/for requirement source
aatm 0.53.0 feather, plotms, viewer, TBD
almawvr (libair) 1.2 + patch from Dirk TBD TBD
blas 3.0-38 browser, feather, logger, plotms, plotserver, viewer, TBD
bnmin1 1.11 almawvr TBD
boost 1.41.0 browser, feather, logger, plotms, plotserver, viewer, TBD
cfitsio 3.030 browser, feather, logger, plotms, plotserver, viewer, TBD
dbus 1.6.12 viewer, plotms, viewer, interactive clean, plotserver  
dbus-cpp 0.9.0 feather, plotms, viewer, TBD
dbus-glib 0.86 python-dbus  
fftw 3.2.2 browser, feather, logger, plotms, plotserver, viewer, TBD
gomp 4.4.4 TBD TBD
gsl 1.13 TBD TBD
lapack 3.0-38 browser, feather, logger, plotms, plotserver, viewer, TBD
libxml2 2.7.7 TBD TBD
libxslt 1.1.17-2 TBD TBD
openssl 0.9.8 libcrypto? TBD
pcre 8.13 SWIG TBD
pgplot 5.3.1 browser, feather, logger, plotserver, viewer, TBD
qt 4.8.5 browser, feather, TBD
qwt 5.2.3 browser, feather, logger, plotms, plotserver, viewer, TBD
rpfits 2.15 TBD TBD
sqlite 3.6.23.1 feather, plotms, viewer, TBD
tix 8.4.0 TBD TBD
wcslib 4.7 browser, feather, logger, plotms, plotserver, viewer, TBD
xerces-c 2.8.0 browser, logger, plotms, plotserver, viewer, TBD

Python Packages

This version of Python is used for CASA scripting. These Python packages are required to implement parts of CASA or by tools used by CASA.

python package required version required by requirement source
dbus 1.2.0   internal dependency
foolscap 0.6.3   internal dependency
ipython 0.10.2 CASA command line interface internal dependency
matplotlib 1.1.0   internal dependency
nose 0.11.4   internal dependency
numpy 1.7.1   customer request
pexpect 2.3   internal dependency
pyfits 3.0.6   customer request
pyOpenSSL 0.10   internal dependency
pytz 2013b   internal dependency
ScientificPython 2.8   customer request
scipy 0.12.0   customer request
setuptools 0.9.5   customer request
twisted 12.0.0   internal dependency
zope interface 3.8.0   IPython

Available Versions

We are auditing our list of supported OSs to determine available versions of required packages. This work is incomplete.

tool minimum Debian 7.0 Fedora 17 OS X 10.7 OS X 10.8 Redhat 5.7 Redhat 6.3 Ubuntu 12.04 LTS
cmake 2.8.5 2.8.9-1 2.8.9-1.fc17 2.8.10.2 2.8.10.2     2.8.7-0ubuntu4
gcc 4.1.2 4.7.2-1 4.7.2-2.fc17 4.2.4 - 4.9-20130512 4.2.4 - 4.9-20130512     4.6.3-1ubuntu5
gfortran 4.1.2 4.7.2-1 4.7.2-2.fc17 4.2.4 - 4.9-20130512 4.2.4 - 4.9-20130512     4.6.3-1ubuntu5
swig 2.0.4 2.0.7-3 2.0.8-1.fc17 2.0.9 2.0.9     2.0.4+really2.0.4-4ubuntu2

library minimum Debian 7.0 Fedora 17 OS X 10.7 OS X 10.8 Redhat 5.7 Redhat 6.3 Ubuntu 12.04 LTS

Sources:

Obsolete - to be removed

The following have been reported as obsolete and will be removed.

obsolete why
antlr-c++ Reported by Darrell
ccmtools Now using SWIG to generate python bindings to C++ code

-- ScottRankin - 2013-05-22
Topic revision: r24 - 2013-11-20, ScottRankin
 

This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding NRAO Public Wiki? Send feedback